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Main 

Objective 

The main goal of this training is to teach the participants all aspects of a static artefact analysis.  

During the first part they are taught how to approach the disassembly of binary code, 

recognize basic programming language structures and navigate through the disassembled 

code. This part is conducted with non-malicious binary code for safety reasons. 

Second part of the exercise focuses on characteristic patterns in assembly code that can be 

found in popular artefacts. The participants will learn to quickly recognize these common 

patterns which adds to the effectiveness of their further work. 

Eventually, the instructor guides the class through real-world samples of known threats 

while gradually increasing level of their complexity. 

Targeted 

Audience 

CSIRT staff involved with the technical analysis of incidents, especially those dealing with 

sample examination and malware analysis. Prior knowledge of assembly language and 

operating systems internals is highly recommended. 

Total Duration 8-12 hours 

Frequency Once for each team member 
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1. Introduction to IDA Pro 

 Opening and closing samples 
During the first part of the training, you will learn how to use IDA Free disassembler, which is a powerful tool allowing 

an analyst to effectively analyse disassembled code. In this training you will examine the binary of the popular SSH 

client – PuTTY3. Since this code is not malicious, you don’t need to worry about accidentally executing it. 

Copy putty.exe sample to the Desktop and start IDA Free disassembler. Click Ok. 

 

Click Go button. You can also check “Don’t display this dialog box again” option to prevent IDA from displaying this 

dialog each time. 

 

                                                           

3 PuTTY: A Free Telnet/SSH Client http://www.chiark.greenend.org.uk/~sgtatham/putty/  (last accessed 11.09.2015) 

http://www.chiark.greenend.org.uk/~sgtatham/putty/
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Open putty.exe file by choosing File->Open… or dragging putty.exe binary onto the disassembler window.  
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Leave all default options set as shown on the screenshot and press Ok button. 
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Now take a look at the directory where putty.exe is located.  

 

When finishing the analysis by either quitting IDA Pro or selecting File->Close, IDA will ask whether to pack database 

files (Pack database (store) - recommended) or leave unpacked files. You can also choose to finish analysis without 

saving any results (DON’T SAVE the database option). 
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 IDA Pro interface 
Load putty.exe as described in the previous step (or open a saved session). 

 

To switch between windows you can use Windows tabs (3). If you accidentally close any of the windows you can 

bring it back using the View->Open sub views menu or a corresponding shortcut key. 
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Right above the window tabs there is an Overview navigator (2) panel.  

 

Switch to Hex View-A window and scroll up and down to observe how it changes your current position (pointed by 

the yellow arrow). 

The last three elements of the IDA workspace are: toolbars area (1) – to quickly access certain IDA functions, graph 

overview (5) – to quickly navigate disassembled code and the output window (6). 

 Exercise 
Take some time to switch between the different data views (windows) and check what type of data is presented in 

each of them. 

 Name a few functions imported by PuTTY executable. 

 What sections are present within executable? 

 What do strings tell you about this binary? 
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Right click on the toolbars (1) and uncheck unnecessary toolbars in the context menu. 

 

In the example below we display the following toolbars: 

 Main 

 Files 

 Navigation -> Jumps 

 Navigation -> Navigation 

 Navigation -> Graph overview 

 Disassembly -> Cross references 

 Graphs 

It is also worth resizing output window (6), which is rarely used during analysis.  

 

Next, rearrange all the windows and toolbars to give IDA a cleaner look. Since the functions window and disassembly 

window will be very frequently used, it is good to have them on top. Moreover, it is also good to maximize IDA 

window if you haven’t done so already. 
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Save the layout using Windows->Save desktop option. 

 

 

Now whenever you start a new analysis or your layout gets messed up you can quickly restore it using Windows-

>Load desktop option. 
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 Disassembly view 
There are two types of the assembly view: text view and graph view. To switch between the text and graph views, 

click on the assembly view (IDA View-A) and press the spacebar. 

 

If you click on jump destination, IDA will highlight destination label as well as a corresponding arrow. 

  

The second type of assembly view is graph view.  
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You can also hover the cursor over branches. IDA will show a small hint window with a code snippet about where a 

branch is leading. 

 

Sometimes you will want to get a higher level grasp of the code flow in the function. In such a situation, it is useful 

to zoom out the graph view with Ctrl + Scroll button. 



Advanced artefact analysis 
Advanced static analysis   

    
 
 
 

15 

 

You can click on almost any name (register, operation, variable, comment, etc.) and IDA will highlight every other 

occurrence of this name. For example, you can highlight push/pop operations to track registry changes or highlight 

a particular registry to track which instructions are changing it. 
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If you would like to see instruction addresses while staying in graph view choose Options->General… and select Line 

prefixes option. 

 

Now when viewing code in graph view, you will also see instruction addresses. For convenience you will use this in 

the rest of the document so you could always easily navigate to the part of the code pointed by the screenshot. 

 



Advanced artefact analysis 
Advanced static analysis   

    
 
 
 

17 

At the end, it is worth mentioning that if IDA doesn’t recognize part of the code as a proper function, graph view will 

be unavailable. You can recognize this situation when instruction addresses in text view are red and it is impossible 

to switch to graph view. 

 

 

 Basic navigation 
One of the easiest ways to navigate through code is to use the functions window. Just find an interesting function 

name and double click it to move to this function instantaneously. For example, go to the sub_4457D6 function. 

 

Moreover, if the functions list is long you can click the functions window and start typing a function name. At the 

bottom of the window, you can observe the characters you have typed and if a function with a given name exists, it 

will be selected automatically. 
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As you may have noticed, some of the functions in the functions list are named differently than sub_XXXXXX. 

Examples of such functions are _fwrite, _strcat, _sscanf, etc. With a few exceptions those are library functions 

statically linked to the binary during compilation. 

If you resize the functions window, such functions will be marked with capital L in sixth column4. 

 

Moreover if you take a look at the overview navigator bar, library functions are marked with cyan colour. 

 

Go back to the WinMain function and look at the group of four calls at the beginning of the routine. 

                                                           

4 To check meaning of other columns refer to https://www.hex-rays.com/products/ida/support/idadoc/586.shtml 
(last accessed 11.09.2015) 

https://www.hex-rays.com/products/ida/support/idadoc/586.shtml
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To quickly navigate to sub_44B2C5, double click its name. 

 

In a similar way, you can also click on data offsets to move to the location of the data in memory. For example, 

double click on aWs2_32_dll, a name given by IDA to the string “ws2_32.dll” defined in memory in section .rdata at 

the address 0x473EF0. 

 

Now to go back to WinMain quickly press the <Esc> key twice. It will move you back to the WinMain routine. 

Respectively, to move forward, press <Ctrl> + <Enter> and you will be back in sub_44B2C5. You can also use the 

Jumps toolbar: 

 

When dealing with large and complicated functions, it is useful to use the small Graph overview window to navigate 

within the code of a function. The Graph overview window should be present whenever disassembly view is active 



Advanced artefact analysis 
Advanced static analysis   

    
 
 
 

20 

and its current mode is graph view. If you accidentally close Graph overview window, open it using View -> Toolbars 

-> Navigation -> Graph overview. 

 

If the function graph is too big to fit your current disassembly view size, your current position will be marked with a 

small dotted rectangle within the Graph overview window. This rectangle will change size whenever you zoom in or 

out of the function graph. 

You can move this rectangle or just click on any part of the Graph overview to move to the chosen part of the 

function. Now try to inspect function sub_44F102 using only the Graph overview window. 

 

Often, you know the particular memory address that you would like to inspect but you don’t know which function it 

belongs to. In such situations, you can use Jump to address feature (Jump -> Jump to address… or press <g>). 

 

In this dialog, you can enter any hexadecimal address within the memory range of analysed binary (e.g. 0x440C74) 

or any name recognized by IDA like a function name or certain label (e.g. sub_40E589, loc_40E5CA). 
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 Exercise 
Take some time to navigate through the various functions of disassembled PuTTY binary. 

 Find function sub_4497AE. What API calls are made within this function?  

 Go to the address 0x406AFB. To which function does this address belong? 

 Go to the address 0x430EAB. Is there anything special about the instructions stored at this address? 

 Functions 
The WinMain function provides a good example of IDA’s analysis capabilities: 

 

You can edit the function prototype by clicking on the function name and choosing Edit->Functions->Set function 

type… from the menu. 

 

Below the function header is a list of local variables (2) and function arguments (3). IDA tracks how those variables 

are used in the code and then tries to suggest their names.  

Local variables will always have negative offsets while function arguments will have positive offsets. 

arg_8 ebp+10 

arg_4 ebp+C 
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arg_0 ebp+8 

ret. addr. ebp+4 

ebp ebp 

var_4 ebp-4 

var_8 ebp-8 

var_C ebp-C 

If you double click on any of the variable names, IDA will open a stack frame window for the current function. 

 

In functions with EBP-based stack frames, all variables are referenced relative to the EBP register. WinMain or 

sub_42FCAD are examples of such functions. 

 

In functions with ESP-based stack frame, the EBP register isn’t preserved and all variables are referenced relative to 

the ESP register.  Example of such a function is sub_40486C. 
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In some situations, IDA doesn’t properly recognize functions. Sometimes, this requires correcting the code first – 

either manually or by a custom script, but sometimes it is enough to tell IDA to create a function at the given address.  

Example of a function that IDA did not properly recognize is code at address 0x430E38: 

 

To create a function, click on the first instruction (push ebp) and choose Edit->Functions->Create function… 
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IDA should now recognize this part of the code as a proper function and you should be able to switch to the graph 

view. 

 

 

If you believe a function was wrongly recognized, you can click on the function’s name in the code and choose Edit-

>Functions->Edit function… to change various function parameters like the function’s start or end address.  
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 Enhancing assembly code 
Go to the function sub_44D262 (0x44D262). This function takes one unknown argument (arg_0) and uses a few 

variables, two of them IDA named FileName and FindFileData. 

 

In the function body you will see a few API calls to functions such as GetWindowsDirectoryA, FindFirstFileA, 

FindNextFileA, GetProcAddress, etc.  

 

 

There are also some unknown calls to an address stored in registers: 
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And calls to functions pointed by some global variable: 

 

Such calls make analysis more difficult because you don’t know where those calls are leading to. 

To start improving code readability, first look at the graph nodes with calls to GetProcAddr.

 

In total, there three such calls in sub_44D262. You can read the name of the function being resolved from the 

value pushed onto stack (CryptAcquireContextA). After the call to GetProcAddress, the result is saved to the 

memory location pointed by dword_47E0C8. 

You can rename this memory location by clicking on dword_47E0C8 and pressing <n> key. Rename it to 

CryptAcquireContextA. 
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After pressing Ok you will be informed that name exceeds 15 characters. Ignore this warning and click Yes. 

 

Now the code should look like this: 

 

Repeat this step for the remaining two calls to GetProcAddress in sub_44D262 (CryptGenRandom, 

CryptReleaseContext). Make sure that you rename the memory locations exactly the same as the names of the 

resolved functions. 

Next, scroll down to the location where the calls to the functions pointed by memory address (call dword_XXXXXX) 

were previously. Notice how they changed? 
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Switch to Analysis tab and click Reanalyze program. 

 

Wait for IDA to finish the analysis and close the IDA Options dialog. Notice how IDA has now added additional 

comments and renamed some variables!  
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Now scroll to the location 0x44D391 where there is a call to eax: 

 

IDA still doesn’t know where this call is made to, but if you highlight eax register and take a look a few blocks above, 

you will notice that eax is assigned with the pointer to CryptAcquireContextA. 

 

To add comment click on call eax and pres <:> (colon): 

 

Comment remaining arguments of CryptAcquireContextA accordingly to this function prototype5 to make it look 

like the following: 

                                                           

5 CryptAcquireContext function https://msdn.microsoft.com/en-
us/library/windows/desktop/aa379886%28v=vs.85%29.aspx (last accessed 11.09.2015) 

https://msdn.microsoft.com/en-us/library/windows/desktop/aa379886%28v=vs.85%29.aspx
https://msdn.microsoft.com/en-us/library/windows/desktop/aa379886%28v=vs.85%29.aspx
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Now you know that 0F0000000h and 1 are the constants passed to CryptAcquireContextA in arguments dwFlags and 

dwProvType. You can check in function reference6 that dwFlags takes the constant with the CRYPT_ prefix while 

dwProvType takes the constant with the PROV_ prefix. You can tell IDA to represent those values as a symbolic 

constant. 

To use symbolic constant representation, right-click on 0F0000000h and choose “Use standard symbolic constant”. 

 

In the next window IDA will display all known standard symbolic constants whose value equals to 0F0000000h. 

Choose constant with CRYPT_ prefix – CRYPT_VERIFYCONTEXT. 

 

Repeat those steps for dwProvType, but this time choosing PROV_RSA_FULL. Now code should look like this: 

                                                           

6 CryptAcquireContext function https://msdn.microsoft.com/en-
us/library/windows/desktop/aa379886%28v=vs.85%29.aspx (last accessed 11.09.2015) 

https://msdn.microsoft.com/en-us/library/windows/desktop/aa379886%28v=vs.85%29.aspx
https://msdn.microsoft.com/en-us/library/windows/desktop/aa379886%28v=vs.85%29.aspx
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Now scroll up to the address 0x44D367. Here you can see a group of nodes making jump to the same location – 

loc_44D3BE. 

 

Further inspection shows that loc_44D3BE is a location of a function epilogue – probably jumped to if something 

earlier fails. Rename this location to func_exit in the same way as renaming memory location. Now all jumps should 

look much more clearly: 
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Group graph nodes used to resolve crypto functions addresses. To do this, go to the graph node at the address 

0x44D2F7 and select graph nodes by clicking on them while holding the <Ctrl> key. 

 

Select all graph nodes starting from 0x44D2F7 up to 0x44D367. 

 

Now right-click on selected nodes and choose Group nodes. 
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In the next window write short description of what grouped nodes are used to. 

 

After clicking Ok all previously selected nodes should be replaced with the single node. To edit node group text or 

temporarily un-collapse group, use pair of new buttons on the node group header. 
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Now go to the location loc_44D2B1 (0x44D2B1). 

 

Take a look at the call ebx instruction. If you select call ebx, you will notice that very similar calls are made in two 

other locations in the function: 
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In each case, two arguments are pushed onto the stack – first some address, and the second one seems to be the 

size of a buffer pointed by the first argument (it is good to comment this!). 

Now if you select only the ebx register you will notice that its value is being assigned once at the beginning of the 

function: 

 

This means that arg_0 is a function pointer and the function pointed by this argument is called three times in our 

function (you can rename arg_0 to func_ptr). Since this seems to be a significant element, it is good to mark all three 

graph nodes where such a call takes place. 

To mark a graph node you will use the node colouring feature. Go back to loc_44D2B1 and click the icon of the colour 

palette in the left upper corner: 
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After clicking Ok node background should become cyan. 

 

Repeat this step for the two remaining graph nodes where a call to ebx takes place. 

One more thing you can do with IDA to improve code readability is to change how IDA presents numerical values. 

By default any numerical value is presented as hexadecimal. Sometimes you would like to view it as a decimal, binary 

or even custom defined constant. To change value format you can right-click on it and choose more suitable format. 
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Additionally in some rare situations it might be also helpful to change the name of some registers. For example, if in 

a given function some register is frequently used for only one purpose—e.g. storing some pointer or constant 

value—it might be good to change its name. This change would only apply to the current function. 

An example of such register in sub_44D262 is edi. The register is first zeroed (xor edi, edi) and then used in rest of 

the function only to compare other values to zero, or push zero onto the stack: 

  

 

 

To rename a register, click on register and press <N> (rename): 
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Now the code should look like this: 

 

 Exercise 
 Find where variable var_8 is used and rename it. 

 Try to rename remaining locations: loc_44D2B1, loc_44D2DA, loc_44D36B, loc_44D3B4. What names would 

you suggest for them? 

 Group three graph nodes checking if functions CryptAcquireContextA, CryptGenRandom and 

CryptReleaseContext were resolved correctly (0x44D36B, 0x44D374, 0x44D37C). 

 Has the code readability of the function improved? 

 Can you guess what function sub_44D262 might be used for? 
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2. Recognizing important functions 

In this exercise, you will use sample of the Slave trojan7 which is a banking trojan first detected by S21sec 

company8. Before continuing, please load slave.exe sample in IDA and wait until the initial auto analysis completes. 

Because you will be now analysing a live malware sample, remember to take all necessary precautions. 

 Using call graphs 
To access the call graph functionality use menu View->Graphs or use the Graphs toolbar. 

 

 

Start by clicking on wWinMain function in the slave.exe sample and then choose to create Xrefs from call graph. 

Note that you need to click on actual function (as on the picture below) and not on function name in function 

prototype. 

 

 

Now you should see WinGraph32 window with newly created call graph for wWinMain function. This Xrefs from 

graph presents all functions called from wWinMain routine (local functions, library functions as well API functions). 

                                                           

7 Sample  
400fbcaaac9b50becbe91ea891c25d71 (MD5) 
https://malwr.com/analysis/OTRiMDk1ODFkOGVjNDhkMzljYzdiZTUzZDUyYjEwM2M/ (last accessed 11.09.2015) 
8 New banking trojan 'Slave' hitting Polish Banks http://securityblog.s21sec.com/2015/03/new-banker-slave-hitting-
polish-banks.html (last accessed 11.09.2015) 

https://malwr.com/analysis/OTRiMDk1ODFkOGVjNDhkMzljYzdiZTUzZDUyYjEwM2M/
http://securityblog.s21sec.com/2015/03/new-banker-slave-hitting-polish-banks.html
http://securityblog.s21sec.com/2015/03/new-banker-slave-hitting-polish-banks.html
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To navigate the graph, use left-mouse button. To zoom in or zoom out, use the toolbar buttons as shown on the 

screen above. 

Now zoom in (or zoom to 100%) to notice the different colours of the graph nodes. 

 

What if you want to check what functions call wWinMain? You can use the Xrefs to call graph. Click on wWinMain 

and choose Xrefs to graph. 
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Create Xrefs to graph for sub_404330. 

 

Xrefs to graphs might be also used to check what functions are referencing particular memory location. As an 

example go to the wWinMain function, click on dword_438120 and choose to create the Xrefs to graph. 
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You should see all functions referencing this memory location.  

 

The third type of graphs are user defined graphs. To create this graph for wWinMain select wWinMain and choose 

User xrefs chart…. 
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As an example, create a graph for wWinMain presenting only references from this function and limiting the graph 

to recursion depth 2. 
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Is newly created graph clearer and easier to follow? 

 

 Exercise 
Take a few minutes to experiment with the other options of user defined graphs. Create a few graphs for functions 

other than wWinMain. 

The last graph type – Function calls, presents a graph of function calls for all recognized functions. 
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You will now analyse call graph of wWinMain function9. 

 

First, notice the top group of three functions (1): sub_406410, sub_406120, sub_401B90. At this point you can 

already suspect that those are important functions because they are called directly from the wWinMain and they 

are calling a lot of APIs. Unfortunately due to the structure of the graph it is hard to tell which API is called by which 

function. To deal with this problem, create a call graph of wWinMain with recursion depth equal to 2. 

Then take a look at sub_401B90. We can see that this function is iterating through the process list (calls to 

Process32FirstW, Process32NextW, etc.).  

 

Next, look at sub_406410. It calls APIs such us RegSetValueExW, CreateDirectoryW, CreateFileW, MoveFileExW. 

                                                           

9 This graph might be slightly different, but if using the same IDA version its general structure should be very similar. 
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Then take a look at sub_406120. It enumerates the registry (RegEnumValueW) and checks some module path 

(GetModuleFileNameW).  

 

Now go back to the general graph (wWinMain) and take a look at function sub_402050 (2). Among the other APIs it 

is also calling CreateRemoteThread and WriteProcessMemory. This tells us that this function is most likely injecting 

some code to other processes (you can also notice that sub_402050 was first called from already checked 

sub_401B90 which was an iterating process list). 

 

Next, take a look at function sub_405760 (3) which is calling many other functions. 

 

If you look closer at the rest of the graph you notice several other potentially interesting functions like sub_4027E0 

performing some file system operations (DeleteFileW, WriteFile, SetFileAttributesW, CreateFileW) or sub_406CA0 

doing some threads operations (ResumeThread, SuspendThread, OpenThread, …). 
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The next thing you might consider doing would be to create separate call graphs for functions such as the previously 

noticed sub_405760.  

 Using cross references 
To use cross references, go to the place where a given object is defined (not referenced), click on the object name 

and press <X> (or select View->Open subviews->Cross references). 

As an example, go to wWinMain function. 

 

To check where the global variable dword_438120 is used double click it to go to the memory location where this 

data variable is defined. 

 

To get a better view and list of all cross references it is best to select variable and press <Ctrl+X> to open Cross 

references dialog. 
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You can also immediately jump to any cross reference by double clicking it. For example, jump to the cross reference 

at the address sub_402540+C5 (if you then want to go back, simply press <Esc>). 

 

Switch to imports view. If the window is not already, open it by choosing View -> Open subviews -> Imports. To make 

searching easier, sort imported functions by name by clicking on the Name column. 

 

Let’s say you want to find which function is injecting code to other processes. To do this, first find the 

WriteProcessMemory function on the imports list and double click it. 
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Next click on the function name and open the Xrefs dialog. 

 

When looking at the imports list one thing that stands out is a complete lack of network related functions. It is rather 

uncommon for a malware to not communicate with any servers. This suggests such functions might be loaded 

dynamically at runtime. Let’s check it by following cross references to GetProcAddress function. 
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As suspected, there are quite a lot calls to GetProcAddress. 

Now go to any cross reference in sub_402860 (or just go to this function), and take a look at calls to GetProcAddress: 

 

Now follow cross references to dword_438108 to check where HttpSendRequestA function is called: 
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You see that there is one call to HttpSendRequestA in sub_402300. Follow this cross reference. 

 

Switch to strings view. If strings view is not open, choose View -> Open subviews -> Strings. 

 

In the strings window, you see a few interesting strings. There is some domain name: www.bizzanalytics.com. Double 

click on this string and follow cross references to it: 
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You see there are two cross references, first one leads to sub_402300 – function you have already found to 

communicate with a C&C server and the second one is a string offset written in memory. 

 

Now go back to the strings window and notice the strings named PR_Write, PR_Read, and PR_Close, which are names 

of functions from the NSPR library used for network communication10. 

 

Let’s examine where those strings are referenced. 

                                                           

10 Netscape Portable Runtime (NSPR) https://developer.mozilla.org/en-US/docs/Mozilla/Projects/NSPR (last accessed 
11.09.2015) 

https://developer.mozilla.org/en-US/docs/Mozilla/Projects/NSPR
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All three of these strings are referenced in two different functions: sub_405390 and sub_405760. If you jump to 

either of those two functions and examine it, you will see references to strings like “HttpQueryInfoA”, 

“InternetReadFile”, “InternetReadFileExA”, “InternetQueryDataAvailable” and “InternetCloseHandle” which are 

network functions used in Internet Explorer web browser.  

  



Advanced artefact analysis 
Advanced static analysis   

    
 
 
 

54 

 Exercise 
Save the results of your current work and open a new sample dexter.exe which is a sample of Dexter malware 

targeting POS systems11. Using techniques presented in this exercise try to pinpoint important functions in 

disassembled code. 

 Find network related functions. 

 Find the installation routine. 

 Find the function performing RAM scraping (reading memory of other processes). 

 Find the process injection routine. 

 Are there any other potentially interesting or suspicious functions? 

 

 

  

                                                           

11 POS malware - a look at Dexter and Decebal http://h30499.www3.hp.com/t5/HP-Security-Research-Blog/POS-
malware-a-look-at-Dexter-and-Decebal/ba-p/6654398 (last accessed 11.09.2015) 

http://h30499.www3.hp.com/t5/HP-Security-Research-Blog/POS-malware-a-look-at-Dexter-and-Decebal/ba-p/6654398
http://h30499.www3.hp.com/t5/HP-Security-Research-Blog/POS-malware-a-look-at-Dexter-and-Decebal/ba-p/6654398
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3. Functions analysis 

 Analysis of network function 
In the previous exercise you found a group of suspicious functions. The next step is to analyse those functions in 

order to better understand their functionality and what they are used for. In this exercise, you will learn the basic 

principles of function analysis: how to start analysis, what to look for and how to understand a function’s role. 

First go to sub_402300 (or 0x402300 address).  

 

For convenience (if you haven’t done it already) rename sub_402300 to f_CnC_func. 
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To check what functions are called within f_CnC_func you need to first deal with calls to global variables: 

 

Using cross references go to the place where value of dword_438104 is set (or just jump (G) to 0x402939): 

 

Rename all global variables used to store addresses of network related functions (make sure you don’t change the 

order or make a typo): 
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Now go back to f_CnC_func and reanalyse code (Options->General->Analysis->Reanalyse program). IDA should add 

additional comments12: 

 

While staying in f_CnC_func, choose View->Open subviews->Function calls. 

                                                           

12 If at some point you notice that your disassembly is lacking some comments (except the ones added manually) in 
comparison to the screenshots in this document you can try repeating this step. Also make sure that you properly 
renamed global variables containing pointers to API functions. 
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Let’s start by analysing if there are any f_CnC_func function arguments: 

 

Go to the place where f_CnC_func is called from following the address 0x40256C that you got from the function 

calls window. 
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You are now at the beginning of the sub_402540.  

Now go back to f_CnC_func to check if ecx register is used for anything. 

 

Rename var_C to this. 

 

Now go to the last block of f_CnC_func (loc_40246A): 
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Rename var_14 to retval. For convenience it is also good to rename label loc_40246A to something like func_exit: 

 

Go to beginning of the function.  

 

For clarity rename var_10 to hInternet. 
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For clarity, rename variables and add symbolic constants. For 0x40233D, right click and select symbolic constant -> 

use standard symbolic constant from the list select “INTERNET_SERVICE_HTTP”. For 0x402343 switch to decimal by 

clicking on it and use shortcut key Shift+H. Also rename var_18 to hConnect. 

 

In the next step, the malware is opening an HTTP request using HttpOpenRequestA. 

 

Hover mouse cursor over szObjectName or double click it. 
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Rename global variable dword_438124 to CnC_hRequest and check the xrefs to it. 

 

 

Now take a look at the next three code blocks (0x4023A6, 0x4023D3, 0x4023DA): 
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In the first block there is a single call to InternetReadFile. 

 

Then there is a loop over block [2] and [3] with an additional call to InternetReadFile in block [3]: 

 

Now let’s analyse block [1] in more detail. 

 

Highlight the edi register and search where in the code its value was last set: 
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Going back to block [1], notice that some variable (var_8) is initialized to zero. Highlight var_8 and check where else 

in the code this variable is used: 

 

 

You see that var_8 is used a few times in block [3]. First in conjunction with memcpy function to specify a number 

of bytes to be copied and later a number of received bytes is added to var_8. This means that var_8 is used to store 

number of received bytes. Knowing all of this you can comment appropriately beginning of the block [1]: 

 

In the second half of block [1] there is a call to InternetReadFile: 

 

Here you see that received data is saved to a Buffer variable which is a memory buffer declared on the stack with 

the size of 4096 bytes (1000h). Moreover the number of received bytes will be saved to the 

dwNumberOfBytesRead variable. 
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Now go to block [2] – the first block of the receive loop. 

 

Now let’s proceed with the analysis to block [3]. 
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At this point, detailed function analysis is done. However, remember that detailed function analysis is not always 

necessary. 

What you have learnt about f_CnC_func: 

 Returns 1 if any data was received 

 Connection is made to the hardcoded URL 

 No POST data is sent in the request to the C&C server 

 There is no processing of received data. Function is used solely to download some data from the server. 
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Received data is saved to a newly allocated memory block. A pointer to this memory is saved to the variable, 

passed as a function argument. 

 Analysis of WinMain 
Now you will perform an analysis of wWinMain function located at address 0x406060. 

 

It also seems that wWinMain is not using any local variables nor referencing any of its arguments. 

 

First go to the last block of the function (loc_40610F) and rename it as func_exit: 
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Now take a look at the first block of the function: 

 

A couple of things take place here. First, you see a call to the sub_402860 function (line 03). If you take a quick look 

at this function you will see it is used to dynamically load a few API functions: 

 

Rename sub_402860 to f_Initialize_APIs. 
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Rename the global variable hHandle at line 12 to hUnnamedMutex. 

Additionally at line 11 some global variable (dword_438120) is initialized to zero. You don’t know yet what this 

variable will be used for in the code but it is good to give it a temporary name, for example var_main_zero. If you 

later see reference to this variable you will immediately know it was first set to zero in the wWinMain function. 

 

 

Check xrefs to the value of dword_437E40? 

 

However the virtual address 0x437E40 is located in an uninitialized part of the data section of slave.exe and 

according to PE-COFF specification13 this memory is automatically initialized to zero. 

                                                           

13 Microsoft PE and COFF Specification https://msdn.microsoft.com/en-us/windows/hardware/gg463119.aspx (last 
accessed 11.09.2015) 

https://msdn.microsoft.com/en-us/windows/hardware/gg463119.aspx
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The next code block is quite interesting. 

 

If the time() result is greater or equal to zero, then the same result is compared to value 0x551B3500 

(1427846400). 

 

In the next two code blocks, the malware tries to create a named mutex “__NTDLL_CORE__” and checks if it 

succeeds. 
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In the next two code blocks, the program calls two functions: sub_406120 and sub_406410. None of those 

functions seem to take any arguments and the second function is called only if the first one returns value zero 

(eax). 

 

At this point you still don’t know what the purpose of the first routine sub_406120 is. 

 

In the next block, the program is creating a new thread. The thread routine is set to sub_401B90. Rename this 

function to f_ThreadFunction. 
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 Analysis of thread function 
In this exercise you will do an analysis of the thread function (f_ThreadFunction - sub_401B90). However, unlike in 

previous examples, you will do only a quick assessment of this function to get a general knowledge about its 

functionality. 

Go to f_ThreadFunction in IDA Free. Notice that IDA highlighted some parts of the code in red.  

 

In this case, it should be enough to tell IDA to reanalyse the code (Options->General->Analysis->Reanalyze 

program) and IDA will fix references to local variables: 

 

Rename the local variable var_264 to PID: 

 

 

Notice that the entire thread function is a big loop, iterating over processes: 
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Go to the block where Process32Next is called and rename the block label to get_proc_next: 

 

Take a look at the beginning of the loop (block [1]).  

 

Next, take a look at blocks [2], [3] and [4]. 
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Next, take a look at [5]. 

 

 

Next, proceed to [6]. 
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To check what anonymous_0 field is, first hover mouse over SystemInfo: 

 

Next go to Structures view (View->Open Subviews->Structures). This view presents all well-known data structures 

recognized by IDA in disassembled code (it is also possible to create custom data structures). 

Next find on the list _SYSTEM_INFO. structure. 
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To expand the structure declaration, click on _SYSTEM_INFO. name and press ‘+’ on numerical keypad. 

 

Here you can see that anonymous_0 field is the first field in _SYSTEM_INFO structure. This means this is a union 

containing information about processor architecture (wProcessorArchitecture). 

 

The next block is quite interesting from an educational point of view. 
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This code is executed only if malware determines that it is running on 64-bit system. The call to IsWow64Process 

suggests that malware checks if web browser process is running under WOW6414. 

 

The second argument (Wow64Process) is a pointer to a BOOL variable used to return information whether given 

process is running under WOW64. 

 

                                                           

14 Windows subsystem allowing 32-bit applications running on 64-bit Windows system 
(https://msdn.microsoft.com/en-us/library/windows/desktop/aa384249%28v=vs.85%29.aspx)  (last accessed 
11.09.2015) 

https://msdn.microsoft.com/en-us/library/windows/desktop/aa384249%28v=vs.85%29.aspx
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Choose Options->General and check the Stack pointer checkbox. 

 

Notice that each instruction changing the stack pointer (push, pop, etc.) is changing the value in this column and 

instructions like mov, xor, add, cmp … are not changing the stack pointer: 

 

 

Hover mouse over IsWow64Process. 
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Click on the call to IsWow64Process and choose Edit->Functions->Change stack pointer… (Alt+K). Next enter value 

0x8 (because function is taking two DWORD sized arguments): 

 

Now IDA should correctly reference all variables making code much clearer. Notice what was previously referenced 

as var_274 is now var_26C: 

 

Going back to the thread function analysis, take a look at block [7] where the single function sub_402050 is called 

just before loop end. 

 

This function takes a single argument (process ID) and from the call graph for this function, you will see it calls APIs 

such as WriteProcessMemory or CreateRemoteThread. This means this function is used to inject code into the 

browser process. 
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Finally code at [8] is executed after Process32NextW returns FALSE (zero). 

  

What you have learnt is that the thread function endlessly iterates over the process list in search of the processes 

of popular web browsers (Mozilla Firefox, Google Chrome and Internet Explorer) to inject some code to such a 

process in sub_402050. What you haven’t checked is how detection of 64-bit process affects code injection. You 

have also skipped a call to sub_401DA0 which is a function using mutexes to prevent injection of code twice to the 

same process. 

 Exercise 
Open the dexter.exe sample (the same as in the previous exercise) and try to analyse the following functions: 

 sub_401E70 – what this function is used for? How does it return a result? 

 sub_402620 – what are the function arguments and how are they used? 

 sub_4022B0 – what is this function used for? 

For each function do only a quick assessment in order to get general understanding of the function and its role. No 

detailed analysis is necessary.  
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4. Anti-disassembly techniques 

In this exercise you will learn some of the more popular anti-disassembly techniques. Note that since those 
techniques affect disassembled code they are usually also a problem during dynamic analysis in which a debugger 
needs to disassemble code as well. 

 Linear sweep vs. recursive disassemblers 
Take a look at hexdump of some executable: 

 

Highlighted bytes represent consecutive assembly instructions: 

E8 34 04 00 00:  call 0x401a20 

E9 58 FD FF FF:  jmp 0x401349 

8B FF: mov edi, edi 

But if you start analysis, for example, at the offset changed by two bytes this would produce completely different 

assembly code. 

 

Red frames mark previously disassembled instructions while highlighted bytes mark new instructions after 

disassembling with changed offset. 

04 00: add al, 0x0 

00 E9: add cl, ch 

58: pop eax 

FD: std 

FF: db 0xFF (incorrect) 

FF 8B FF 55 8B EC: dec dword [ebx-0x1374aa01] 
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The difference between a linear sweep and recursive disassembler is how a disassembler follows consecutive 

instructions. A linear sweep disassembler tries to disassemble all the code in a code section of an executable. The 

beginning of a new instruction is always marked with the end of a previous instruction and it doesn’t depend on the 

instruction type. That is, if there were some bytes injected between instructions, the disassembler would try to 

interpret them as another instruction. 

For example: 

 

In this example, a linear disassembler would try to disassemble bytes 6D 73 67… as an instruction instead of 

interpreting it as text string. Resulting disassembly would look as follows: 
 

 

Notice that the first two instructions (push, jmp) are disassembled properly but the rest of the code is completely 

different. 

 Anti-disassembly techniques 
Below there is a short summary of common anti-disassembly techniques: 

 Inserting garbage bytes. 

This technique works by inserting random bytes in chosen parts of the code. The intention is to make a 

disassembler interpret those bytes as a normal code, what would then lead to incorrect disassembly. This 

technique is usually used in conjunction with some other technique. 

 Return address manipulation. 

This is one of several execution flow manipulation techniques. It works by changing the return address of 

the current function. This way, while a disassembler is expecting a function to return to the address after a 

call, the instruction the function would return to is in a completely different part of the code. 

 Middle instruction jump. 

In this technique one instruction (e.g. push, mov) is used to hide another instruction. 

 Always taken jumps. 

This technique works by using conditional jumps for which the condition will be always met. Since 

disassembler will likely not know this, it will try to disassemble bytes following this instruction. 

 Indirect calls based on runtime value. 

If the jump or call is made to the dynamically computed address/offset then a recursive disassembler won’t 

know which address should be analysed next. Additionally, if this is a call instruction, a disassembler won’t 

know calling convention of the destination function and how a called function is changing the stack pointer. 
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 Structured Exception Handling (SEH) 

Structured Exception Handling (SEH) is a mechanism normally used to handle exceptions in programs. It can 

be also used to obscure execution flow by first installing an exception handler routine and then triggering 

an exception in some part of the code. As a consequence, program execution will be switched to the 

exception handler routine. 

 Inserting junk code. 

This technique works by inserting instructions in the code that have no direct effect on execution and doesn’t 

change program result. The only aim of this technique is to make disassembled code less clear and harder 

to analyse (it is usually difficult for the analyst to distinguish real instructions from the junk code). 

 Dynamic API loading. 

Based on what API functions the malware is calling, you can try to predict its functionality and also recognize 

the important parts of the code. To make such analysis harder, malicious code frequently dynamically loads 

important API functions so that they are not present by default in the import address table. 

 Analysis of anti-disassembly techniques 
In this exercise you will analyse a specially prepared binary file (non-malicious) which is using various anti-

disassembly techniques. 

Start by opening antidisasm.exe in IDA: 

 

You can see here a group of calls to various functions. Each function is using different anti-disassembly techniques 

and then returns some value in the eax register. The task is to tell what value is returned by each function using 

only static analysis techniques. 

4.3.1 Analysis of a call to loc_40101A 
First go to function at 0x40101A. 
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Notice that at the beginning of loc_40101A there is a strange call (call $+5). 

 

Then you add 10h to eax value and call to the address of the newly computed eax value. 

 

At this point you know that the eax value is 0x401032 (0x401022+0x10). Unfortunately this leads us right into the 

middle of the junk code and it seems there is no instruction at this address. 

 

Select all junk code and then right click it and choose undefined (or press <U>): 
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Next click on the byte at the address 0x401032 and press <C> to convert it to code. Notice also the string 

“Fantastic!” right after a call to eax. 

 

Now the code should be much clearer. You can also read return value of loc_40101A which is 0x1337. 
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To sum up, in this function you have seen two anti-disassembly techniques. First there was an indirect call to 

dynamically computed address. IDA didn’t know what address was called and thus it just tried to disassemble next 

instruction which happened to be inline embedded string (second technique). This resulted in creation of junk 

code instead of valid assembly instructions. 

4.3.2 Analysis of a call to loc_401045 
The second function which you will analyse is the function at loc_401045. 

 

Highlight the eax register to check where its value is set.  

Notice the red coloured cross reference – suggesting that something is wrong here. 

 

Select the highlighted instruction and convert it to data (use Undefine or press <U>). 
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Now select the byte at 0x40104B and press <C> to define code. Do the same with the byte at 0x401050 (jz 

instruction). After this, you should see code similar to this one: 

 

Now select the byte at 0x40104B and press <C> to define code. Do the same with the byte at 0x401050 (jz 

instruction). 

 

This means that in the middle of the push instruction was hidden another jump instruction. 
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To proceed, go to the undefined instruction at 0x40105D and create code at the address 0x40105E. After those 

operations code should look as follow: 

 

Now you can clearly see return value set to 0x4096. Notice that after retn instruction a few garbage bytes were 

added to prevent IDA from properly disassembling instructions where the eax value is being set. 

The screenshot below shows the execution flow of a routine before making any changes to it: 

 

To sum up, in this routine you have seen a few anti-disassembly techniques. The most notable one is the jump into 

the middle of another instruction. In this scenario, a push instruction was used to conceal another jump 

instruction. You have also seen usage of a conditional jump that is always taken as well as the use of garbage bytes 

to desynchronize disassembled code. 

4.3.3 Analysis of a call to sub_401065 
The next call is made to sub_401065. This time, IDA recognized this code as a normal function: 
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What you see here is that the eax register is first zeroed, then some function sub_40107D is called (with argument 

0x1000) and finally you add 0x1000 to eax. The question is whether sub_40107D changes eax to return some value. 

Let’s take a look at sub_40107D: 

 

It looks like the only thing this function is doing with eax is first loading arg_0 value (0x1000) and then adding another 

0x1000. Thus after the function returns, eax should have value 0x2000. Does it mean that return value of sub_401065 

is 0x3000 (0x2000+0x1000)? 

As you might have suspected, it is not that easy. Take a look what happens just before sub_40107D returns: 
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First load to edx the stack address of the first argument and then subtract 4 bytes from edx. What does the address 

stored in edx point to now? Remember stack frame structure: 

arg_0 ebp+8 

ret. addr. ebp+4 

ebp ebp 

After subtraction, edx points to the return address stored on the stack. Then, in the third line, we add 0x2B to the 

return address value. This means that return address of the function was changed and sub_40107D will now return 

to a different place of the code.  

To check where the function will now return go back to the sub_401065: 

 

The original return address should be 0x401074. But you know it was increased by 0x2B. This means that function 

sub_40107D will return to the address 0x40109F (0x401074+0x2B). Switch from graph view to the text view and 

search for this address. 

 

Not surprisingly you see some junk code stored at this location. Undefine (<U>) this code and then create new code 

(<C>) starting at the address 0x40109F. 
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You have just found final eax value which is 0xC0DE! 

To sum up, in this section, you have seen a quite popular anti-disassembly technique which is return address 

replacement. Malicious code trying to deceive the disassembler replaces return address in call to a certain function 

so that it would point to a completely different part of the code than the disassembler expects. 

4.3.4 Analysis of a call to sub_4010B2 
Now you will analyse a call to subroutine sub_4010B2. 

 

… 

 

If you go to this function you will see a long disassembled code with many operations on the eax register. However 

if you take a closer look at the code you might notice groups of instructions that are not doing anything (some of 

them might change some flags but this is not relevant in this example). 
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This is a little simplified version of a technique, in which blocks of junk instructions having no effect on the program 

execution and only making manual analysis harder are injected into real code. 

The only way of dealing with such code is to try to look for any repeated pattern of junk code in disassembly. If you 

notice such pattern you might try to eliminate it by writing script which would overwrite junk code with NOP 

instructions or highlight it with some colour. However writing scripts in IDA is not a part of this course. 

If you analyse the code a little more, you will notice that only three instructions have an effect on the final eax value: 

 

 

 

This means that the final eax value will be 0x1500. 
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4.3.5 Analysis of a call to sub_40116D 
The last call which you will analyse is a call to sub_40116D: 

 

In this routine, the eax register is seemingly set to 0xEBFE value. However you should immediately notice the 

instruction mov fs:0, esp which tells us that a new Structured Exception Handler (SEH) is being installed15. 

Information about all exception handlers is stored in the list of EXCEPTION_REGISTRATION structures: 

_EXCEPTION_REGISTRATION struc 

     prev    dd      ? 

     handler dd      ? 

 _EXCEPTION_REGISTRATION ends 

This structure consists of two fields. The first field (prev) is a pointer to the next EXCEPTION REGISTRATION structure 

while the second field (handler) is a pointer to exception handler function. 

The pointer to the first EXCEPTION_REGISTRATION structure (list head) is always stored in the first DWORD value 

of the Thread Information Block (TIB). On the Win32 platform, the TIB address is stored in FS register, thus by 

executing mov fs:0, esp, you are setting the first exception handler to the EXCEPTION_REGISTRATION structure 

created on the stack. 

 

In the case of sub_40116D, the stack would look as follows (after SEH installation): 

                                                           

15 To get more information about SEH refer to https://www.microsoft.com/msj/0197/exception/exception.aspx (last 
accessed 11.09.2015)  

https://www.microsoft.com/msj/0197/exception/exception.aspx
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The next question should be whether any exception is triggered in this function? Yes, take a look at the ecx register: 

First, it is zeroed and then the program tries to write a DWORD value to the address pointed by this register. 

However, because ecx points to unallocated address 0x00000000 this will cause an exception 

(STATUS_ACCESS_VIOLATION – 0xC0000005) and program execution would be switched to the installed exception 

handler. 

 

But what is the address of the exception handler routine? In this example you see that the value 0x15232A1 is being 

pushed onto stack as an exception handler. But this is not a valid address of any function. Indeed, notice the xor 

instruction xoring the exception handler address on the stack with value 0x1122300. This means that the real 

exception handler address is: 

0x15232A1 xor 0x1122300 = 0x4011A1 

To calculate xor value you can use IDA calculator (View -> Calculator):  

 

Now switch from graph view to text view and search for an address 0x4011A1: 
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Repeat steps from previous exercises to convert data at 0x4011A1 to code: 

 

 Exercise 
After completing the analysis of all anti-disassembly techniques in the sample, try to repeat this exercise but using 

OllyDbg instead. This executable is not performing any malicious actions so you don’t need to worry about 

accidentally executing it. When debugging in OllyDbg, try to follow execution using Step into (F7) function instead of 

stepping over analysed functions. 

 How does disassembled code in OllyDbg differ from the code initially disassembled by IDA? 

 Was analysis easier in OllyDbg or IDA? 
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